$re = '/#(?:\b[\s\S]*?\b#|\w+)/';
$str = '#The test# rain in #SPAIN stays mainly in the #plain';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);