const regex = /.*[adehj].*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*[adehj].*', 'gm')
const str = `AT+AB Bypass`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);