use strict;
my $str = 'AT+AB Bypass';
my $regex = qr/.*[adehj].*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";