$re = '/.*[adehj].*/m';
$str = 'AT+AB Bypass';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;