package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(.*?)<(.*?)>`)
var str = `--> Welcome to Stack Overflow<http://stackoverflow.com>
Take the tour<http://stackoverflow.com/tour> |Need help?<http://stackoverflow.com/help> `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}