// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*(.*?)<(.*?)>").unwrap();
let string = "--> Welcome to Stack Overflow<http://stackoverflow.com>
Take the tour<http://stackoverflow.com/tour> |Need help?<http://stackoverflow.com/help> ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}