re = /\s*(.*?)<(.*?)>/
str = '--> Welcome to Stack Overflow<http://stackoverflow.com>
Take the tour<http://stackoverflow.com/tour> |Need help?<http://stackoverflow.com/help> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end