#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!^\[[\d\-]+\]$)\[[\w][\w\-]*[\w]+\]$"
Local $sString = "[Primeiro-Exemplo]" & @CRLF & _
"[Segundo-Exemplo-Valido]" & @CRLF & _
"[3-Exemplo-Valido]" & @CRLF & _
"[-3-Exemplo-Valido]" & @CRLF & _
"[1-2-3]" & @CRLF & _
"[Evento-4]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")