const regex = /^(?!^\[[\d\-]+\]$)\[[\w][\w\-]*[\w]+\]$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!^\\[[\\d\\-]+\\]$)\\[[\\w][\\w\\-]*[\\w]+\\]$', 'mg')
const str = `[Primeiro-Exemplo]
[Segundo-Exemplo-Valido]
[3-Exemplo-Valido]
[-3-Exemplo-Valido]
[1-2-3]
[Evento-4]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}