using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!^\[[\d\-]+\]$)\[[\w][\w\-]*[\w]+\]$";
string input = @"[Primeiro-Exemplo]
[Segundo-Exemplo-Valido]
[3-Exemplo-Valido]
[-3-Exemplo-Valido]
[1-2-3]
[Evento-4]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}