#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=cardNo\"?\s?:\s?\"\d{0,100})\d(?!\d{0,3}\")"
Local $sString = "cardNo":"10929291929312911131"" & @CRLF & _
"(cardNo:"10929291929312911131",cardType:"CREDIT")" & @CRLF & _
""cardNo" : "10929291929312911131" " & @CRLF & _
"creditCardData(cardNo: "10929291929312911131",cardType:"CREDIT") –"
Local $sSubst = "X"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)