$re = '/(?<=cardNo\"?\s?:\s?\"\d{0,100})\d(?!\d{0,3}\")/m';
$str = 'cardNo":"10929291929312911131"
(cardNo:"10929291929312911131",cardType:"CREDIT")
"cardNo" : "10929291929312911131"
creditCardData(cardNo: "10929291929312911131",cardType:"CREDIT") –';
$subst = "X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;