use strict;
my $str = 'cardNo":"10929291929312911131"
(cardNo:"10929291929312911131",cardType:"CREDIT")
"cardNo" : "10929291929312911131"
creditCardData(cardNo: "10929291929312911131",cardType:"CREDIT") –';
my $regex = qr/(?<=cardNo\"?\s?:\s?\"\d{0,100})\d(?!\d{0,3}\")/mp;
my $subst = 'X';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";