package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\d+(?:,\d+)+]`)
var str = `[,][123,1][,][456,2][,][789,3][,][,][,][,][,][,][,][,]
[123]
[123,1,2,34]
[123,1,2]
[]
[1,,2]
[,1,2]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}