// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\d+(?:,\d+)+]").unwrap();
let string = "[,][123,1][,][456,2][,][789,3][,][,][,][,][,][,][,][,]
[123]
[123,1,2,34]
[123,1,2]
[]
[1,,2]
[,1,2]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}