re = /\[\d+(?:,\d+)+]/m
str = '[,][123,1][,][456,2][,][789,3][,][,][,][,][,][,][,][,]
[123]
[123,1,2,34]
[123,1,2]
[]
[1,,2]
[,1,2]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end