import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<trkpt\\s(?=.*?(\\blat\\s*=\\s*[\"']?\\s*\\b[\\d.]+)).*?(\\blon\\s*=\\s*[\"']?\\s*\\b[\\d.]+)";
final String string = "<?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"yes\"?>\n"
+ "<trkpt lat=\"53.188185\" lon=\"7.216993\"></trkpt>\n"
+ "<trkpt lat=\"53.184541\" lon=\"7.217456\"></trkpt>\n"
+ "<trkpt lat=\"53.188185\" lon=\"7.216993\"/> (Kurzschreibweise)\n"
+ "<trkpt lat='53.188185' lon='7.216993'></trkpt> (anderen Anführungszeichen)\n"
+ "<trkpt lat=\"53.188185\" lon=\"7.216993\"></trkpt>\n"
+ "<trkpt lon=\"7.216993\" lat=\"53.188185\"></trkpt>\n"
+ "<trkpt lat=\"53.188185\" foo='\"' bar='\"' lon=\"7.216993\"></trkpt>\n"
+ "<trkpt lat=\"53.188185\" foo=\"\" bar=\">\" lon=\"7.216993\"></trkpt>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}