const regex = /<trkpt\s(?=.*?(\blat\s*=\s*["']?\s*\b[\d.]+)).*?(\blon\s*=\s*["']?\s*\b[\d.]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<trkpt\\s(?=.*?(\\blat\\s*=\\s*["\']?\\s*\\b[\\d.]+)).*?(\\blon\\s*=\\s*["\']?\\s*\\b[\\d.]+)', 'g')
const str = `<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<trkpt lat="53.188185" lon="7.216993"></trkpt>
<trkpt lat="53.184541" lon="7.217456"></trkpt>
<trkpt lat="53.188185" lon="7.216993"/> (Kurzschreibweise)
<trkpt lat='53.188185' lon='7.216993'></trkpt> (anderen Anführungszeichen)
<trkpt lat="53.188185" lon="7.216993"></trkpt>
<trkpt lon="7.216993" lat="53.188185"></trkpt>
<trkpt lat="53.188185" foo='"' bar='"' lon="7.216993"></trkpt>
<trkpt lat="53.188185" foo="" bar=">" lon="7.216993"></trkpt>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}