import re
regex = re.compile(r"<trkpt\s(?=.*?(\blat\s*=\s*[\"']?\s*\b[\d.]+)).*?(\blon\s*=\s*[\"']?\s*\b[\d.]+)")
test_str = ("<?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"yes\"?>\n"
"<trkpt lat=\"53.188185\" lon=\"7.216993\"></trkpt>\n"
"<trkpt lat=\"53.184541\" lon=\"7.217456\"></trkpt>\n"
"<trkpt lat=\"53.188185\" lon=\"7.216993\"/> (Kurzschreibweise)\n"
"<trkpt lat='53.188185' lon='7.216993'></trkpt> (anderen Anführungszeichen)\n"
"<trkpt lat=\"53.188185\" lon=\"7.216993\"></trkpt>\n"
"<trkpt lon=\"7.216993\" lat=\"53.188185\"></trkpt>\n"
"<trkpt lat=\"53.188185\" foo='\"' bar='\"' lon=\"7.216993\"></trkpt>\n"
"<trkpt lat=\"53.188185\" foo=\"\" bar=\">\" lon=\"7.216993\"></trkpt>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")