import Foundation
let pattern = #"<trkpt\s(?=.*?(\blat\s*=\s*["']?\s*\b[\d.]+)).*?(\blon\s*=\s*["']?\s*\b[\d.]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<trkpt lat="53.188185" lon="7.216993"></trkpt>
<trkpt lat="53.184541" lon="7.217456"></trkpt>
<trkpt lat="53.188185" lon="7.216993"/> (Kurzschreibweise)
<trkpt lat='53.188185' lon='7.216993'></trkpt> (anderen Anführungszeichen)
<trkpt lat="53.188185" lon="7.216993"></trkpt>
<trkpt lon="7.216993" lat="53.188185"></trkpt>
<trkpt lat="53.188185" foo='"' bar='"' lon="7.216993"></trkpt>
<trkpt lat="53.188185" foo="" bar=">" lon="7.216993"></trkpt>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)