#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:(?<= [+][1-9])|(?<= [1-9])|(?<= ))([2-9][0-9]{9})\b"
Local $sString = "abcd +12125551212 xyz should match starting at 212 " & @CRLF & _
"abcd +2125551212 xyz should NOT match (+ sign only)" & @CRLF & _
"abcd 2125551212 xyz match OK!" & @CRLF & _
"abcd+12125551212 xyz should NOT match (no white space at start)" & @CRLF & _
"abcd 12125551212 xyz should match starting at 212" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")