import re
regex = re.compile(r"(?:(?<= [+][1-9])|(?<= [1-9])|(?<= ))([2-9][0-9]{9})\b", flags=re.IGNORECASE)
test_str = ("abcd +12125551212 xyz should match starting at 212 \n"
"abcd +2125551212 xyz should NOT match (+ sign only)\n"
"abcd 2125551212 xyz match OK!\n"
"abcd+12125551212 xyz should NOT match (no white space at start)\n"
"abcd 12125551212 xyz should match starting at 212\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")