$re = '/(?:(?<= [+][1-9])|(?<= [1-9])|(?<= ))([2-9][0-9]{9})\b/i';
$str = 'abcd +12125551212 xyz should match starting at 212
abcd +2125551212 xyz should NOT match (+ sign only)
abcd 2125551212 xyz match OK!
abcd+12125551212 xyz should NOT match (no white space at start)
abcd 12125551212 xyz should match starting at 212
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);