#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^ ]+) : .*$"
Local $sString = "abcd\eft : abdeff::" & @CRLF & _
"Part1 : Part2" & @CRLF & _
"Pa rt1 : Part2" & @CRLF & _
"Part1 :Part2" & @CRLF & _
"Part1: Part2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")