re = /^([^ ]+) : .*$/m
str = 'abcd\\eft : abdeff::
Part1 : Part2
Pa rt1 : Part2
Part1 :Part2
Part1: Part2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end