using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^ ]+) : .*$";
string input = @"abcd\eft : abdeff::
Part1 : Part2
Pa rt1 : Part2
Part1 :Part2
Part1: Part2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}