$re = '/.+@.+(\.|:).+/m';
$str = 'ß@ê.∆
hello@haroen.me
test@127.0.0.1
k@::1
test@localhost
test@something.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);