// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).+@.+(\.|:).+").unwrap();
let string = "ß@ê.∆
hello@haroen.me
test@127.0.0.1
k@::1
test@localhost
test@something.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}