re = /.+@.+(\.|:).+/m
str = 'ß@ê.∆
hello@haroen.me
test@127.0.0.1
k@::1
test@localhost
test@something.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end