#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)http://(?:.*\.|.*)imdb.com/(?:t|T)itle(?:\?|/)(..\d+)"
Local $sString = "http://www.imdb.com/Title/tt2618986"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")