using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http://(?:.*\.|.*)imdb.com/(?:t|T)itle(?:\?|/)(..\d+)";
string input = @"http://www.imdb.com/Title/tt2618986";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}