package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)http://(?:.*\.|.*)imdb.com/(?:t|T)itle(?:\?|/)(..\d+)`)
var str = `http://www.imdb.com/Title/tt2618986`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}