re = /http:\/\/(?:.*\.|.*)imdb.com\/(?:t|T)itle(?:\?|\/)(..\d+)/i
str = 'http://www.imdb.com/Title/tt2618986'
# Print the match result
str.match(re) do |match|
puts match.to_s
end