# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\G((?:[^$\\]|\$\d|\$(?![^$]*\$)|\$[^$]*+\$)*+)\\/$1"/g;t' <<< "I have $50 to \spend\. I just $\bar$ remembered that I have another $30 dollars $\left$ from my last \paycheck\. Lone $ \at the end\"