use strict;
my $str = 'I have $50 to \\spend\\. I just $\\bar$ remembered that I have another $30 dollars $\\left$ from my last \\paycheck\\. Lone $ \\at the end\\';
my $regex = qr/\G((?:[^$\\]|\$\d|\$(?![^$]*\$)|\$[^$]*+\$)*+)\\/p;
my $subst = '$1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";