$re = '/\G((?:[^$\\\\]|\$\d|\$(?![^$]*\$)|\$[^$]*+\$)*+)\\\\/';
$str = 'I have $50 to \\spend\\. I just $\\bar$ remembered that I have another $30 dollars $\\left$ from my last \\paycheck\\. Lone $ \\at the end\\';
$subst = "$1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;