import Foundation
let pattern = #"\G((?:[^$\\]|\$\d|\$(?![^$]*\$)|\$[^$]*+\$)*+)\\"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I have $50 to \spend\. I just $\bar$ remembered that I have another $30 dollars $\left$ from my last \paycheck\. Lone $ \at the end\"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)