package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s+`)
var str = ` Big Spaces Throughout
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}