use strict;
my $str = ' Big Spaces Throughout
';
my $regex = qr/^\s+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";