$re = '/^\s+/';
$str = ' Big Spaces Throughout
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;