import re
regex = re.compile(r"^\s+")
test_str = (" Big Spaces Throughout \n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)