package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bDOB ((?:(?:(?:3[01]|[12][0-9]|0?[1-9]) )?[A-Za-z]+ )?\d{4})\b`)
var str = `DOB 23 Jun 1959; alt. DOB 23 Jun 1958
DOB 1959; alt. DOB 1958
DOB Jun 1958`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}