const regex = new RegExp('\\bDOB ((?:(?:(?:3[01]|[12][0-9]|0?[1-9]) )?[A-Za-z]+ )?\\d{4})\\b', 'g')
const str = `DOB 23 Jun 1959; alt. DOB 23 Jun 1958
DOB 1959; alt. DOB 1958
DOB Jun 1958`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}