import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bDOB ((?:(?:(?:3[01]|[12][0-9]|0?[1-9]) )?[A-Za-z]+ )?\\d{4})\\b";
final String string = "DOB 23 Jun 1959; alt. DOB 23 Jun 1958\n"
+ "DOB 1959; alt. DOB 1958\n"
+ "DOB Jun 1958";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}