// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bDOB ((?:(?:(?:3[01]|[12][0-9]|0?[1-9]) )?[A-Za-z]+ )?\d{4})\b").unwrap();
let string = "DOB 23 Jun 1959; alt. DOB 23 Jun 1958
DOB 1959; alt. DOB 1958
DOB Jun 1958";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}