const regex = /(?P<Spring>Spring\.)(?P<FunctionName>[a-zA-Z0-9]+)([^\(]+\()(?P<Arguments>([^\)]+))\)([^>]+>)(?P<ReturnType>[^\n]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<Spring>Spring\\.)(?P<FunctionName>[a-zA-Z0-9]+)([^\\(]+\\()(?P<Arguments>([^\\)]+))\\)([^>]+>)(?P<ReturnType>[^\\n]+)', '')
const str = `Spring.GetVectorFromHeading
( number heading ,test value)
-> ReturnType ReturnName
converted into
\$Spring\$FunctionName = function \$FunctionName(\$Arguments) assert(\$Arguments); return \$ReturnType end
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}