import re
regex = re.compile(r"(?P<Spring>Spring\.)(?P<FunctionName>[a-zA-Z0-9]+)([^\(]+\()(?P<Arguments>([^\)]+))\)([^>]+>)(?P<ReturnType>[^\n]+)")
test_str = ("Spring.GetVectorFromHeading\n\n"
" ( number heading ,test value)\n\n"
"-> ReturnType ReturnName\n\n"
"converted into\n\n"
"$Spring$FunctionName = function $FunctionName($Arguments) assert($Arguments); return $ReturnType end\n\n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")