#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi).*(dog)"
Local $sString = "dog dog cat fish" & @CRLF & _
"dog dog cat fish" & @CRLF & _
"dog dog dog cat fish" & @CRLF & _
"dog fish" & @CRLF & _
"dog dog gone it" & @CRLF & _
"dog dog woof"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")