re = /.*(dog)/mi
str = 'dog dog cat fish
dog dog cat fish
dog dog dog cat fish
dog fish
dog dog gone it
dog dog woof'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end