// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi).*(dog)").unwrap();
let string = "dog dog cat fish
dog dog cat fish
dog dog dog cat fish
dog fish
dog dog gone it
dog dog woof";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}